Compilation error yambo-4.5.0

Having trouble compiling the Yambo source? Using an unusual architecture? Problems with the "configure" script? This is the place to look.

Moderators: Davide Sangalli, andrea marini, Daniele Varsano, andrea.ferretti, Conor Hogan, myrta gruning

Forum rules
If you have trouble compiling Yambo, please make sure to list:
(1) the compiler (vendor and release: e.g. intel 10.1)
(2) the architecture (e.g. 64-bit IBM SP5)
(3) if the problems occur compiling in serial/in parallel
(4) the version of Yambo (revision number/major release version)
(5) the relevant compiler error message
Post Reply
michele guerrini
Posts: 11
Joined: Thu Mar 28, 2019 10:53 am

Compilation error yambo-4.5.0

Post by michele guerrini » Thu Feb 06, 2020 4:38 pm

Dear developers, I am trying to compile the latest version (v-4.5.0) of the code but a the moment I keep getting the following error:

>>>[Making qe_pseudo]<<<
<command-line>: warning: missing whitespace after the macro name
make[2]: Entering directory `/home/bepmguer/codes/yambo-4.5.0/lib/qe_pseudo'
Makefile:98: *** missing separator (did you mean TAB instead of 8 spaces?). Stop.
make[2]: Leaving directory `/home/bepmguer/codes/yambo-4.5.0/lib/qe_pseudo'
make[1]: *** [int-libs] Error 2
make[1]: Leaving directory `/home/bepmguer/codes/yambo-4.5.0'
yambo build failed

any suggestion on how to solve it ? Thanks
Dr. Michele Guerrini
Humboldt-Universität zu Berlin
Institut für Physik und IRIS Adlershof
Zum Grossen Windkanal 6, 12489 Berlin, Germany
e-mail: guerrini@physik.hu-berlin.de
Skype: merlin__88

andrea.ferretti
Posts: 123
Joined: Fri Jan 31, 2014 11:13 am

Re: Compilation error yambo-4.5.0

Post by andrea.ferretti » Thu Feb 06, 2020 5:04 pm

Dear Michele,

I have the impression something is not working with your precompiler (either CPP or FPP).
Can you post more information (compiler, config.log, config/report file) ?

take care
Andrea
Andrea Ferretti, PhD
CNR-NANO-S3 and MaX Centre
via Campi 213/A, 41125, Modena, Italy
Tel: +39 059 2055322; Skype: andrea_ferretti
URL: http://www.nano.cnr.it

michele guerrini
Posts: 11
Joined: Thu Mar 28, 2019 10:53 am

Re: Compilation error yambo-4.5.0

Post by michele guerrini » Thu Feb 06, 2020 6:02 pm

sure, here's attached the config.log
You do not have the required permissions to view the files attached to this post.
Dr. Michele Guerrini
Humboldt-Universität zu Berlin
Institut für Physik und IRIS Adlershof
Zum Grossen Windkanal 6, 12489 Berlin, Germany
e-mail: guerrini@physik.hu-berlin.de
Skype: merlin__88

andrea.ferretti
Posts: 123
Joined: Fri Jan 31, 2014 11:13 am

Re: Compilation error yambo-4.5.0

Post by andrea.ferretti » Fri Feb 07, 2020 3:14 pm

Dear Michele,

according to your config.log, you have issued configure more or less as follows:

Code: Select all

./configure --enable-hdf5-par-io --enable-memory-profile --enable-open-mp \
            --enable-int-linalg --enable-par-linalg --enable-netcdf-hdf5 \
            FC=mpiifort CC=mpicc CXX=mpicxx
which reproduces the problem also on my machine (indeed related to the C precompiler).

I have fixed it my using the following flags:

Code: Select all

./configure --enable-hdf5-par-io --enable-memory-profile --enable-open-mp \
            --enable-int-linalg --enable-par-linalg --enable-netcdf-hdf5 \
            FC=ifort CC=icc MPIFC=mpiifort
Hope it helps
Andrea
Andrea Ferretti, PhD
CNR-NANO-S3 and MaX Centre
via Campi 213/A, 41125, Modena, Italy
Tel: +39 059 2055322; Skype: andrea_ferretti
URL: http://www.nano.cnr.it

Post Reply