compillation problem in Cygwin environment

Having trouble compiling the Yambo source? Using an unusual architecture? Problems with the "configure" script? This is the place to look.

Moderators: Daniele Varsano, andrea.ferretti, andrea marini, Conor Hogan, myrta gruning

Forum rules
If you have trouble compiling Yambo, please make sure to list:
(1) the compiler (vendor and release: e.g. intel 10.1)
(2) the architecture (e.g. 64-bit IBM SP5)
(3) if the problems occur compiling in serial/in parallel
(4) the version of Yambo (revision number/major release version)
(5) the relevant compiler error message

compillation problem in Cygwin environment

Postby nulakani » Tue Nov 21, 2017 6:03 pm

Dear Sir
Greetings

Recently, i have tried the yambo installation on a cygwin based linux environment. first i did configuration using 1) ./configure command and next i have issued 2) make all. The complilation went on well except the yambo linking. I have serched the fouram for the possible clarification for this kind of errors and unable to find the same. I have attached the config.log file for your persual. This is the error message on the machine

---------------------------------------------------------------------------------------------
">>>[Linking yambo]<<<
make[2]: Entering directory '/cygdrive/f/NNV/SOFT/YM/driver'
/cygdrive/f/NNV/SOFT/YM/driver/driver.c: In function ‘main’:
/cygdrive/f/NNV/SOFT/YM/driver/driver.c:117:13: warning: ‘optind’ redeclared without dllimport attribute: previous dllimport ignored [-Wattributes]
extern int optind;
^

/usr/lib/gcc/x86_64-pc-cygwin/4.9.2/../../../../x86_64-pc-cygwin/bin/ld: cannot find -lxcf90
collect2: error: ld returned 1 exit status
Makefile:84: recipe for target 'yambo' failed
make[2]: *** [yambo] Error 1
make[2]: Leaving directory '/cygdrive/f/NNV/SOFT/YM/driver'
Makefile:191: recipe for target 'yambo' failed
make[1]: *** [yambo] Error 2
make[1]: Leaving directory '/cygdrive/f/NNV/SOFT/YM'
yambo build failed
--------------------------------------------------------------------

I have also tried with the older version Yambo-3.4.1. It has installed witout any error.

Please helpme to solve this issue.

With best regards
Venkat
CSIR-CLRI, India.
You do not have the required permissions to view the files attached to this post.
nulakani
 
Posts: 1
Joined: Tue Nov 21, 2017 7:36 am

Re: compillation problem in Cygwin environment

Postby Daniele Varsano » Wed Nov 22, 2017 10:36 am

Dear Venkat,
from your config.log file I can see you configured specifying a libxc path:
Code: Select all
$ ./configure --with-libxc-path=/cygdrive/f/NNV/SOFT/YM/lib/libxc/libxc-y2.0.3/ x86_64

and it looks that yambo has having problem linking with your xc libs.
After a make clean_all, reconfigure without specifying the libxc path:
Code: Select all
./configure

yambo will download the needed libraries and compile them.

Best,

Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 1950
Joined: Tue Mar 17, 2009 2:23 pm


Return to Compilation

Who is online

Users browsing this forum: No registered users and 3 guests

cron