Problem in Yambo installation

Having trouble compiling the Yambo source? Using an unusual architecture? Problems with the "configure" script? This is the place to look.

Moderators: Daniele Varsano, andrea.ferretti, andrea marini, Conor Hogan, myrta gruning

Forum rules
If you have trouble compiling Yambo, please make sure to list:
(1) the compiler (vendor and release: e.g. intel 10.1)
(2) the architecture (e.g. 64-bit IBM SP5)
(3) if the problems occur compiling in serial/in parallel
(4) the version of Yambo (revision number/major release version)
(5) the relevant compiler error message

Problem in Yambo installation

Postby barnali » Wed Jan 31, 2018 9:44 am

Respected Sir
I am trying to install YAMBO-3.4.1 in HPC as an interface of quantum espresso. So I have installed Quantum espresso-6.2.1 successfully

Next I have tried to install yambo-3.4.1 version and configured successfully with the following command-

./configure --with-iotk='/home/sarkaru/project/sarkaru/QE/qe-6.2.1/S3DE/iotk' --with-p2y=6.2.1
Then for compiling I have used the command ‘make yambo interfaces’
But get the following error
…………………………………………………………………………………………………………………..
libtool: ignoring unknown tag F77
libtool: compile: gfortran -pipe -O3 -funroll-loops -ffast-math -ffree-line-length-none -c libxc_funcs.f90 -o libxc_la-libxc_funcs.o
libtool: ignoring unknown tag F77
libtool: compile: gfortran -pipe -O3 -funroll-loops -ffast-math -ffree-line-length-none -c libxc.f90 -o libxc_la-libxc.o
/cvmfs/soft.computecanada.ca/nix/var/nix/profiles/16.09/include/stdc-predef.h:1:
1:

/* Copyright (C) 1991-2016 Free Software Foundation, Inc.
1
Error: Invalid character in name at (1)
/cvmfs/soft.computecanada.ca/nix/var/nix/profiles/16.09/include/stdc-predef.h:2:
3:

This file is part of the GNU C Library.
1
Error: Unclassifiable statement at (1)
……………………………………………………………..
Error: Invalid character in name at (1)
/cvmfs/soft.computecanada.ca/nix/var/nix/profiles/16.09/include/stdc-predef.h:57
:1:

/* We do not support C11 <threads.h>. */
1
Error: Invalid character in name at (1)
make[4]: *** [Makefile:1891: libxc_la-libxc.lo] Error 1
make[3]: *** [Makefile:437: all] Error 2
make[2]: *** [Makefile:334: all-recursive] Error 1
make[1]: *** [Makefile:265: all] Error 2
make: *** [Makefile:80: libs] Error 2
………………………………………………………………………………………………………………………
Why this error appeared? Did I miss anything?
Could you please guide me to fix this problem? Here I have attached the config.log.
Thanking you

Sincerely
Barnali Bhattacharya
Ph.D student
Assam university
India
You do not have the required permissions to view the files attached to this post.
barnali
 
Posts: 25
Joined: Sat Nov 08, 2014 5:53 am

Re: Problem in Yambo installation

Postby Daniele Varsano » Wed Jan 31, 2018 9:57 am

Dear Barnali,
as you can see in the yambo documentation:
http://www.yambo-code.org/doc/databases/p2y_direct.php

QE >=6.2 requires yambo >= 4.2

Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 2086
Joined: Tue Mar 17, 2009 2:23 pm

Re: Problem in Yambo installation

Postby barnali » Wed Jan 31, 2018 12:09 pm

config.log
Respected Daniele Varsano

Thanks a lot for your quick reply. Now I am trying to install yambo-4.2.1 version along with quantum espresso -6.2 version.
I have used the following command for configure the yambo-4.2.1

./configure --with-iotk-path='/home/sarkaru/project/sarkaru/QE/qe-6.2.1/S3DE/iotk' --with-p2y-version=6.2.1

Then for compiling I have used the command ‘make interfaces’

But get the following error
…………………………………………………………………………………………………………………..
>>>[Linking a2y]<<<
make[2]: Entering directory '/project/6006031/sarkaru/QE/yambo-4.2.1/interfaces/a2y'
cd /home/sarkaru/project/sarkaru/QE/yambo-4.2.1/interfaces/a2y; /home/sarkaru/project/sarkaru/QE/yambo-4.2.1/sbin/moduledep.sh defs_datatypes.o hdr_io.o a2y_KSS_file_name.o a2y_i.o a2y_db1.o a2y_wf.o > /home/sarkaru/project/sarkaru/QE/yambo-4.2.1/interfaces/a2y/make.dep
defs_datatypes.F hdr_io.F a2y_KSS_file_name.F a2y_i.F a2y_db1.F a2y_wf.F /bin/sh: echo$: command not found
make[2]: *** [Makefile:85: a2y] Error 127
make[2]: Leaving directory '/project/6006031/sarkaru/QE/yambo-4.2.1/interfaces/a2y'
make[1]: *** [Makefile:212: a2y] Error 2
make[1]: Leaving directory '/project/6006031/sarkaru/QE/yambo-4.2.1'
a2y build failed
………………………………………………………………………………………………………………………

Could you please guide me to fix this problem? Here I have attached the config.log.
Thanking you

Sincerely
Barnali Bhattacharya
Ph.D student
Assam university
India
You do not have the required permissions to view the files attached to this post.
barnali
 
Posts: 25
Joined: Sat Nov 08, 2014 5:53 am

Re: Problem in Yambo installation

Postby Daniele Varsano » Thu Feb 01, 2018 12:00 pm

Dear Barnali,
Have you problems in compiling yambo or just the interfaces?

Try the following steps:
Code: Select all
make clean_all
./configure
make yambo interfaces


and report again together with your config.log and the config/setup file?

Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 2086
Joined: Tue Mar 17, 2009 2:23 pm

Re: Problem in Yambo installation

Postby barnali » Tue Feb 13, 2018 8:53 am

Respected Daniele,
As per your suggestion, for yambo installation, I have used the following command-

make clean_all
./configure
make yambo interfaces

But found the following error

>>>[Linking yambo]<<<
make[1]: Entering directory '/project/6006031/sarkaru/QE/yambo-4.2.1/driver'
cd /home/sarkaru/project/sarkaru/QE/yambo-4.2.1/driver; /home/sarkaru/project/sarkaru/QE/yambo-4.2.1/sbin/moduledep.sh yambo_driver.o > /home/sarkaru/project/sarkaru/QE/yambo-4.2.1/driver/make.dep
yambo_driver.F /bin/sh: echo$: command not found
make[1]: *** [Makefile:85: yambo] Error 127
make[1]: Leaving directory '/project/6006031/sarkaru/QE/yambo-4.2.1/driver'
make: *** [Makefile:192: yambo] Error 2

With this mail I have attached the config.log.
Please help me to solve this problem.
Thanking you.
sincerely
Barnali
You do not have the required permissions to view the files attached to this post.
barnali
 
Posts: 25
Joined: Sat Nov 08, 2014 5:53 am

Re: Problem in Yambo installation

Postby Daniele Varsano » Wed Feb 14, 2018 9:20 am

Dear Barnali,
the problem is probably due to the fact you are mixing intel and gnu compilers.
Try to do configure by using:
Code: Select all
./configure CPP='icc -E'

Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 2086
Joined: Tue Mar 17, 2009 2:23 pm


Return to Compilation

Who is online

Users browsing this forum: No registered users and 1 guest

cron