Compiling on HPE/SGI ICE XA

Having trouble compiling the Yambo source? Using an unusual architecture? Problems with the "configure" script? This is the place to look.

Moderators: Daniele Varsano, andrea.ferretti, andrea marini, Conor Hogan, myrta gruning

Forum rules
If you have trouble compiling Yambo, please make sure to list:
(1) the compiler (vendor and release: e.g. intel 10.1)
(2) the architecture (e.g. 64-bit IBM SP5)
(3) if the problems occur compiling in serial/in parallel
(4) the version of Yambo (revision number/major release version)
(5) the relevant compiler error message

Compiling on HPE/SGI ICE XA

Postby andrew.downs » Mon May 06, 2019 9:36 pm

Hello,

Using Intel 2017 as my compiler and SGIMPT 2.18 as my MPI stack, it seems like 'configure' gets confused.

At the end, it shows::

# - COMPILERS -
#
# FC kind = gfortran GNU Fortran (GCC) 4.8.5 20150623 (Red Hat 4.8.5-36)
# MPI kind= Intel(R) MPI Library 2017 Update 1 for Linux* OS
#
# [ CPP ] icc -E -ansi -D_MPI -D_FFTW -D_TIMING
# [ FPP ] gfortran -E -P -cpp -D_MPI -D_FFTW -D_TIMING -D_MPI -D_FFTW -D_TIMING
# [ CC ] mpiicc -O2 -D_C_US -D_FORTRAN_US
# [ FC ] mpiifort -O3 -g -mtune=native
# [ FCUF] -O0 -g -mtune=native
# [ F77 ] mpiifort -O3 -g -mtune=native
# [ F77U] -O0 -g -mtune=native
# [Cmain]
#

I don't want it to use the system's gfortran (which is ancient as you can see) but I want it to use the proper intel fortran pre-processor

when I configure with "configure FPP=ifort" I get errors, so I'm missing something. Is there a better way to set it?

Thank you.
Andrew Downs
Customer Support
andrew.downs
 
Posts: 7
Joined: Fri Dec 22, 2017 4:04 pm

Re: Compiling on HPE/SGI ICE XA

Postby Daniele Varsano » Tue May 07, 2019 8:17 am

Dear andrew.downs ,
please sign your post with your name and affiliation, you can do once for all by filling your signature in the user profile of the forum.
It seems that something is not set properly in your path. What it does worry is
Code: Select all
FC kind = gfortran
.
What happens if you specify directly the fortran preprocessor as:
Code: Select all
FPP="fpp -free -P"

or alternatively:
Code: Select all
FPP="ifort -fpp"

If it fails to recognize it, please post the config.log file.

Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 1948
Joined: Tue Mar 17, 2009 2:23 pm

Re: Compiling on HPE/SGI ICE XA

Postby andrew.downs » Tue May 07, 2019 2:47 pm

Daniele,

FPP="fpp -free -P" results in the same behavior as not setting FPP

FPP="ifort -fpp" results in an error:

checking fortran 90 modules inclusion flag... -I
configure: testing C-preprocessor icc -E -ansi
checking if C precompiler works on C source... yes
configure: testing FC-preprocessor ifort -fpp
checking if FC precompiler works on FC source... no
configure: error: Found FC precompiler problems in processing FC source.



I looked at my $PATH and 'ifort' is in my path before gfortran is, but both are available. The gfortran Yambo is finding is the -really- old one that's built into the base-system. Is there a way to tell Yambo to ignore gfortran entirely? Is gfortran required?

Thank you
Andrew Downs
Customer Support
andrew.downs
 
Posts: 7
Joined: Fri Dec 22, 2017 4:04 pm

Re: Compiling on HPE/SGI ICE XA

Postby Daniele Varsano » Thu May 09, 2019 1:01 pm

Dear Andrew,
can you please post your config.log file?

Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 1948
Joined: Tue Mar 17, 2009 2:23 pm


Return to Compilation

Who is online

Users browsing this forum: No registered users and 1 guest

cron