Do not run in parallel

Having trouble compiling the Yambo source? Using an unusual architecture? Problems with the "configure" script? This is the place to look.

Moderators: Davide Sangalli, andrea marini, Daniele Varsano, andrea.ferretti, Conor Hogan, myrta gruning

Forum rules
If you have trouble compiling Yambo, please make sure to list:
(1) the compiler (vendor and release: e.g. intel 10.1)
(2) the architecture (e.g. 64-bit IBM SP5)
(3) if the problems occur compiling in serial/in parallel
(4) the version of Yambo (revision number/major release version)
(5) the relevant compiler error message
Post Reply
sdwang
Posts: 212
Joined: Fri Apr 09, 2010 12:30 pm

Do not run in parallel

Post by sdwang » Fri May 21, 2010 6:13 pm

Dear developers:

I have compiled yambo in an Linux PC cluster . There are no errors neither in the configure nor the
compilation steps. Actually it runs perfectly in "serial" .
However if I want to run yambo in parallel it fails to run. According to the configuration options, It is pressumably
compiled in parallel. But in the end It seems that it was not.
Any idea of the problem?

The details of the configure and compilation are below.

Thanks
S D Wang

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
1. Compiler: ifort=9.0
gcc-3.4.6
2. Architecture: Linux PC cluster. Compilation in parallel
4. Yambo: yambo-3.2.1-r.448

5. Configure options: (in attach you will find the config.log file)

$ ./configure --with-iotk=/home/sdwang/espresso-4.1.2/iotk/ --with-p2y=4.0 --with-mpi=/usr/local/mpich/lib/libmpichf90.a --with-netcdf=no

7. The message that appeared in the end of the configure step is:

###>>>
.
.
.
.
# [ ] Double precision
# [X] Redundant compilation
# [X] MPI
# [X] PW (4.0) support
# [ ] ETSF I/O support
# [ ] SCALAPACK
# [ ] NETCDF/Large Files
# [XX ] Built-in BLAS/LAPACK/LOCAL
#
....
...
...
###<<<

8. In order to run yambo in serial I have to skip MPI initialization, that is, I type

$ yambo -N

and it runs succesfully.

8. In order to run yambo in parallel I type

$ mpirun -machinefile node_file -np 2 yambo

and the message is:

###>>>
yambo : invalid option -- p

This is yambo 3.2.1 rev.448
Usage: yambo -h -H -J <opt> -V <int> -F <opt> -I <opt> -O <opt> -C <opt> -N -D -S -i -o <opt> -t <opt> -c -x -b -p <opt> -g <opt> -y <opt>
Try `yambo -H' for more information
###<<<
You do not have the required permissions to view the files attached to this post.
S. D. Wang
IMU,HOHHOT,CHINA
E-mail: sdwang@imu.edu.cn

User avatar
myrta gruning
Posts: 305
Joined: Tue Mar 17, 2009 11:38 am
Contact:

Re: Do not run in parallel

Post by myrta gruning » Sun May 23, 2010 8:23 pm

Dear Shudong Wang

this is a known problem (see this topic)
Contrary to what Conor wrote here, my knowledge is that in spite to a lot of attempts the problem was never solved. Since (at least from my experience) the problem appears only with the old mpich on some architectures, and this is now replaced by mpich2, I do not believe the problem will be solved in the future.
My advice is really, if possible, to use a different mpi. For example you may upgrade to mpich2 or using openmpi. Both are not having this problem.
If it is really not possible, I can try to help you further.

Let me know,
m
Dr Myrta Grüning
Atomistic Simulation Centre
Queen's University Belfast - Northern Ireland

http://www.researcherid.com/rid/B-1515-2009

sdwang
Posts: 212
Joined: Fri Apr 09, 2010 12:30 pm

Re: Do not run in parallel

Post by sdwang » Mon May 24, 2010 2:32 am

Thank you!I will try it.
S. D. Wang
IMU,HOHHOT,CHINA
E-mail: sdwang@imu.edu.cn

User avatar
Conor Hogan
Posts: 143
Joined: Tue Mar 17, 2009 12:17 pm
Contact:

Re: Do not run in parallel

Post by Conor Hogan » Tue May 25, 2010 11:46 am

myrta gruning wrote: Contrary to what Conor wrote here, my knowledge is that in spite to a lot of attempts the problem was never solved.
Oops! I stand corrected :D
Dr. Conor Hogan
CNR-ISM, via Fosso del Cavaliere, 00133 Roma, Italy;
Department of Physics and European Theoretical Spectroscopy Facility (ETSF),
University of Rome "Tor Vergata".

Post Reply