Segm. Fault when running hBN_2D

Various technical topics such as parallelism and efficiency, netCDF problems, the Yambo code structure itself, are posted here.

Moderators: Daniele Varsano, andrea.ferretti, andrea marini, Conor Hogan, myrta gruning

Segm. Fault when running hBN_2D

Postby plasmon » Fri Aug 24, 2018 2:40 am

Dear developers,

I am new to YAMBO and I am trying to follow the example of hBN_2D downloaded from the yambo tutorial website.
I run successfully the DFT, q2y and yambo initialization, but failed when I was trying to run the photonic spectra by the yambo.in generated by yambo -o c -k hartree, with the error information,



__ __ _______ __ __ _______ _______
| | | || _ || |_| || _ || |
| |_| || |_| || || |_| || _ |
| || || || || | | |
|_ _|| || || _ | | |_| |
| | | _ || ||_|| || |_| || |
|___| |__| |__||_| |_||_______||_______|


<---> [01] CPU structure, Files & I/O Directories
<---> [02] CORE Variables Setup
<---> [02.01] Unit cells
<---> [02.02] Symmetries
<---> [02.03] RL shells
<---> [02.04] K-grid lattice
<---> [02.05] Energies [ev] & Occupations
<---> [03] Transferred momenta grid
<---> [04] Optics
<---> [LA] SERIAL linear algebra
<---> [DIP] Checking dipoles header
<---> [x,Vnl] computed using 2 projectors
<---> [WF] Performing Wave-Functions I/O from ./SAVE[admin:30255] *** Process received signal ***
[admin:30255] Signal: Segmentation fault (11)
[admin:30255] Signal code: Address not mapped (1)
[admin:30255] Failing at address: 0x7ffef9a59d2c
[admin:30255] [ 0] /lib64/libpthread.so.0[0x370b60f7e0]
[admin:30255] [ 1] /usr/lib64/libblas.so.3(cdotc_+0x68)[0x2ae08a284508]
[admin:30255] [ 2] yambo[0x5f020f]
[admin:30255] [ 3] yambo[0x4fed6a]
[admin:30255] [ 4] yambo[0x48fb6e]
[admin:30255] [ 5] yambo[0x487312]
[admin:30255] [ 6] yambo[0x49bbcc]
[admin:30255] [ 7] yambo[0x47f995]
[admin:30255] [ 8] yambo[0x40ccea]
[admin:30255] [ 9] yambo[0x407fdd]
[admin:30255] [10] /lib64/libc.so.6(__libc_start_main+0xfd)[0x370ae1ed1d]
[admin:30255] [11] yambo[0x406df9]
[admin:30255] *** End of error message ***
Segmentation fault (core dumped)


Could you please tell me how to fix this problem? Thank you!

Hao Zhang
Dr. Hao Zhang
Department of Optical Science and Engineering, Fudan University,Shanghai 200433, China
http://homepage.fudan.edu.cn/zhanghao/
plasmon
 
Posts: 7
Joined: Thu Aug 23, 2018 9:18 am
Location: Fudan University, Shanghai, China

Re: Segm. Fault when running hBN_2D

Postby Daniele Varsano » Fri Aug 24, 2018 9:25 am

Dear Hao,
please sign your post with your affiliation, this is a rule od the forum. You can do once for all, by filling the signature field in your profile.
A possibility of the error is something weird in the compilation.
You can try to recompile yambo adding the following option in the configure:
./configure --enable-int-linalg --other_options

to see if there is some incompatibility in the linear algebra libraries you are linking.
If the problem persist, please post here your config.log file.

Remember to do a
make clean_all
before recompiling,


Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 1948
Joined: Tue Mar 17, 2009 2:23 pm

Re: Segm. Fault when running hBN_2D

Postby plasmon » Fri Aug 24, 2018 1:07 pm

it works now. thank you!

Daniele Varsano wrote:Dear Hao,
please sign your post with your affiliation, this is a rule od the forum. You can do once for all, by filling the signature field in your profile.
A possibility of the error is something weird in the compilation.
You can try to recompile yambo adding the following option in the configure:
./configure --enable-int-linalg --other_options

to see if there is some incompatibility in the linear algebra libraries you are linking.
If the problem persist, please post here your config.log file.

Remember to do a
make clean_all
before recompiling,


Best,
Daniele
Dr. Hao Zhang
Department of Optical Science and Engineering, Fudan University,Shanghai 200433, China
http://homepage.fudan.edu.cn/zhanghao/
plasmon
 
Posts: 7
Joined: Thu Aug 23, 2018 9:18 am
Location: Fudan University, Shanghai, China


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 1 guest