metallic system

Concerns any physical issues arising during the setup step (-i option). This includes problems with symmetries, k/q-point sets, and so on. For technical problems (running in parallel, etc), refer to the Technical forum.

Moderator: Daniele Varsano

metallic system

Postby martinspenke » Sun Jun 21, 2015 9:29 pm

Dear Daniele,

I try to get the band gap of NiO, but unfortunately yambo recognizes the system as metallic because of smearing.
Is there any remedy to get ride of smearing and at the same time being able to run a calculation for a spin polarized material ?
Setting temperature to zero, does not help.

QE input file :
-------------------
&control
calculation = 'scf',
tstress = .false.,
tprnfor = .false.,
pseudo_dir = "../",
outdir = "../",
wf_collect=.TRUE.,
prefix='nio',
/
&system
ibrav= 0, celldm(1)=7.93, nat= 4, ntyp= 3,
ecutwfc = 30.0, ecutrho = 300.0,
input_dft='pbe',
occupations='smearing', smearing='mv', degauss=0.02,
nspin=2,
starting_magnetization(2)= 0.5, starting_magnetization(3)=-0.5,
/
&electrons
mixing_beta = 0.3
conv_thr = 1.0d-5, diago_david_ndim=32,
/
CELL_PARAMETERS
0.50 0.50 1.00
0.50 1.00 0.50
1.00 0.50 0.50
ATOMIC_SPECIES
O 1. O.pbe-mt_fhi.UPF
Ni1 1. Ni.pbe-mt_fhi.UPF
Ni2 1. Ni.pbe-mt_fhi.UPF
ATOMIC_POSITIONS crystal
O 0.25 0.25 0.25
O 0.75 0.75 0.75
Ni1 0.0 0.0 0.0
Ni2 0.5 0.5 0.5
K_POINTS automatic
4 4 4 0 0 0

Bests
Martin
Last edited by martinspenke on Mon Jun 22, 2015 2:43 am, edited 1 time in total.
Martin Spenke, PhD Student
Theoretisch-Physikalisches Institut
Universit├Ąt Hamburg, Germany
martinspenke
 
Posts: 149
Joined: Tue Apr 08, 2014 6:05 am

Re: metallic system

Postby Daniele Varsano » Sun Jun 21, 2015 9:45 pm

Dear Martin,
yambo do recalculate the Fermi level so setting ElecTemp to zero and playing with OccTresh in the input setup should do the job.
Please note that the QE smearing amount (degauss) is read by yambo and the occupation is calculated as Fermi occupation, when using different smearing function it can gives to very different smearing amount.
Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 2026
Joined: Tue Mar 17, 2009 2:23 pm

Re: metallic system

Postby Zahra Taghipour » Tue Sep 01, 2015 3:33 am

Hello,

I am trying to use Yambo in order to improve the DFT's band gap of my system.
I have this problem that Yambo sees my system as Metallic. I have not used smearing in this calculation, though.
I tried to follow your instructions on making ElecTemp equal to zero in the initialization:
{
Nelectro= 18.00000 # Electrons number
ElecTemp= 0.000000 K # Electronic Temperature
BoseTemp=-1.000000 eV # Bosonic Temperature
}
Yet I get non-zero ElectTemp in my r-setup:
{
Fermi Level [ev]: 5.876251
VBM / CBm [ev]: 0.00 0.00
Electronic Temp. [ev K]: 0.1000E-3 1.160
Bosonic Temp. [ev K]: 0.1000E-3 1.160
El. density [cm-3]: 0.300E+24
States summary : Full Metallic Empty
0001-0007 0008-0010 0011-0600

[WARNING]Metallic system
}
The resultant correction was negligible when I proceeded with these values!

I was wondering if setting ElecTemp=zero is necessary for band gap correction for such metallic systems, at all?! if not, How could I get band gap correction when Yambo sees my system as metallic?!

Thank you in advance for your help.

Zahra Taghipour
Research Assistant,
UNM, USA
Zahra Taghipour
 
Posts: 23
Joined: Mon Aug 17, 2015 5:56 am

Re: metallic system

Postby Daniele Varsano » Tue Sep 01, 2015 11:40 am

Dear Zahara,
can you post your input and report files? And eventually also the qe output as well?

Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 2026
Joined: Tue Mar 17, 2009 2:23 pm

Re: metallic system

Postby martinspenke » Tue Sep 01, 2015 3:15 pm

Dear Zahra,

I used smearing, set degauss=0.001, and got an insulating instead of a metallic system.

Bests
Martin
Martin Spenke, PhD Student
Theoretisch-Physikalisches Institut
Universit├Ąt Hamburg, Germany
martinspenke
 
Posts: 149
Joined: Tue Apr 08, 2014 6:05 am

Re: metallic system

Postby Zahra Taghipour » Tue Sep 01, 2015 8:59 pm

Dear Daniele,

Attached, you could find the results from QE and Yambo.
My system is a large unit cell of 90 atoms consisting of 4 different elements. These results are for the simple case of GaSb, though.
My main goal is to correct DFT's band gap. However, this is impossible when Yambo specifies the system as Metallic (w/ or w/o smearing). I would appreciate if you could tell me how to correct for the band gap in this case?!

Thank You,
Best,
Zahra
You do not have the required permissions to view the files attached to this post.
Zahra Taghipour
 
Posts: 23
Joined: Mon Aug 17, 2015 5:56 am

Re: metallic system

Postby Daniele Varsano » Tue Sep 01, 2015 9:28 pm

Dear Zahra,
for what I can see form your report, your ElecTemp specified in input has been not recognized. At the end of report the mirror of the input files is reported:
Code: Select all
 | ElecTemp=0.1000E-3     eV    # Electronic Temperature


This is probably due to the fact you specified in the input file:
Code: Select all
ElecTemp= 0.000000    K

and K it is not recognized. Try to specify the electronic temperature in eV.
Next, I do not know if qe insert a small smearing by default, if this is the case you could try to specify occupations="fixed".

Please fill your signature with your affiliation, you can do it once for all in your user preference.

Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 2026
Joined: Tue Mar 17, 2009 2:23 pm


Return to Initialization

Who is online

Users browsing this forum: No registered users and 1 guest

cron