Running Si example

Concerns any physical issues arising during the setup step (-i option). This includes problems with symmetries, k/q-point sets, and so on. For technical problems (running in parallel, etc), refer to the Technical forum.

Moderator: Daniele Varsano

Running Si example

Postby appalakondaiah » Fri Jan 19, 2018 5:06 am

Dear all,
I am very new to Yambo with pwscf and starting the calculations for Si as mentioned in tutorials. In First step, I tested the calculations in my local computer and successful in reproduce reference files. On the next, I followed the same in my cluster and struck with below error and cludeless

"[FFT-HF/Rho] Mesh size: 12 12 12Segmentation fault (core dumped)"

Briefly, followed below steps for Si example inputs as in tutorial

1st step: " pwscf scf and nscf calculations"
2nd step : p2y -F data-file.xml
3rd step : yambo -i
4th step : yambo (below is the output)
<---> [WARNING]Spatial Inversion not found among the given symmetry list
<---> [02.03] RL shells
<---> [02.04] K-grid lattice
<---> [02.05] Energies [ev] & Occupations
<---> [03] Transferred momenta grid
<---> [04] Timing Overview
<---> [05] Game Over & Game summary
5th step: yambo -x -g n -p p (modified necessary things as mentioned in tutorial)
6th step: yambo -F yambo.in

In the the 6th step, I exited with the error

<---> [WARNING]Spatial Inversion not found among the given symmetry list
<---> [02.03] RL shells
<---> [02.04] K-grid lattice
<---> [02.05] Energies [ev] & Occupations
<---> [03] Transferred momenta grid
<---> [04] Dynamic Dielectric Matrix (PPA)
<---> [05] Bare local and non-local Exchange-Correlation
<---> [WF] Performing Wave-Functions I/O from ./SAVE
<---> [FFT-HF/Rho] Mesh size: 12 12 12Segmentation fault (core dumped)


Kindly, suggested me the solution. I am using qe-6.1 with Yambo 4.2.0 Revision 109 versions.

Thanking you in adavance
with regards
S. Appalakondaiah
postdoctoral scholar
Sungkyunkwan University
Suwon
South Korea
appalakondaiah
 
Posts: 5
Joined: Thu Jan 18, 2018 7:02 am

Re: Running Si example

Postby Daniele Varsano » Fri Jan 19, 2018 10:52 am

Dear S. Appalakondaiah,
it is not easy to understand what is going wrong in your cluster.
If you post your config.log file or better the ./config/setup file we can have a look if there is something odd in the compilation as for instance link to libraries compiled with different compilers.
You can try to configure adding --enable-int-linalg option
./configure --enable-int-linalg

Best,

Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 1948
Joined: Tue Mar 17, 2009 2:23 pm

Re: Running Si example

Postby appalakondaiah » Sat Jan 20, 2018 5:36 am

Dear Daniele

Thank you for the reply and I reconfigured Yambo with your suggestion. Now it is working and also have finished testing for Si and MoS2 at low level parameter settings.

with regards
S. Appalakondaiah
postdoctoral scholar
Sungkyunkwan University
Suwon
South Korea
appalakondaiah
 
Posts: 5
Joined: Thu Jan 18, 2018 7:02 am


Return to Initialization

Who is online

Users browsing this forum: No registered users and 1 guest