Issue in running Yambo

Run-time issues concerning Yambo that are not covered in the above forums.

Moderators: andrea marini, Daniele Varsano, Conor Hogan, myrta gruning

Post Reply
lamia
Posts: 12
Joined: Mon Dec 05, 2016 5:09 pm

Issue in running Yambo

Post by lamia » Sun Dec 09, 2018 5:10 am

Dear YAMBO developer,

I have an issue in running Yambo with the version yambo-master.So, when I use p2y it runs successfully. However, if I try to run the second step using 'yambo' I get the following message error:

~> yambo
yambo: cannot access CORE database (SAVE/*db1 and/or SAVE/*wf)

Sorry to bother if there is already a reply in the forum I did not see.
Taouil Lamia
University of Mohammed V
Faculty of science - Rabat
Morocco

Online
User avatar
Daniele Varsano
Posts: 2128
Joined: Tue Mar 17, 2009 2:23 pm
Contact:

Re: Issue in running Yambo

Post by Daniele Varsano » Sun Dec 09, 2018 8:13 am

Dear Taouil,
please provide more information in order to spot the problem.
Are you running Yambo in the directory where the SAVE directory is present? Please post the output of:
ls -ltr ./SAVE
and also the last line of the standard output of the p2y calculation.

Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/

lamia
Posts: 12
Joined: Mon Dec 05, 2016 5:09 pm

Re: Issue in running Yambo

Post by lamia » Sun Dec 09, 2018 2:26 pm

Dear Daniele,

Thank you for your prompt reply.
I am running Yambo in the case.save directory. The SAVE directory doesn't exist. I cant' create it.
In fact, I am blocked at this point. After I run p2y, I can't do anything.
And the last line of the standard output of the p2y calculation:
<---> Symmetries...[SI no]......[-I no]...[TR yes]Segmentation fault (core dumped)

Best,
Lamia
Taouil Lamia
University of Mohammed V
Faculty of science - Rabat
Morocco

Online
User avatar
Daniele Varsano
Posts: 2128
Joined: Tue Mar 17, 2009 2:23 pm
Contact:

Re: Issue in running Yambo

Post by Daniele Varsano » Mon Dec 10, 2018 9:10 am

Dear Taouil Lamia,
ok, so the problem is that p2y did not run properly and hence Yambo cannot be run.
In order to spot the problem, can you post in attachment your scf/nscf quantum espresso input file, and eventually
also the used pseudopotential?

Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/

lamia
Posts: 12
Joined: Mon Dec 05, 2016 5:09 pm

Re: Issue in running Yambo

Post by lamia » Fri Dec 14, 2018 11:37 am

Dear Daniele,
Sorry for my delayed reply, I just read your post. Please find the attached files and thank you for your help.
regards,
Lamia
You do not have the required permissions to view the files attached to this post.
Taouil Lamia
University of Mohammed V
Faculty of science - Rabat
Morocco

Online
User avatar
Daniele Varsano
Posts: 2128
Joined: Tue Mar 17, 2009 2:23 pm
Contact:

Re: Issue in running Yambo

Post by Daniele Varsano » Sat Dec 15, 2018 11:53 am

Dear Taouil,
the problem you are facing is due to the fact that the vdW functional your are using it is not supported.
Have a look to this post:
viewtopic.php?f=7&t=1500&p=7184&hilit=vdW#p7184

As suggested by Dr. Ferretti, you can do your structural relaxation using the vdW functional, where taing into account
the vdW interaction can be crucial, and next calculate the ground state electronci structure (scf/nscf) by using GGA functionals.

Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/

lamia
Posts: 12
Joined: Mon Dec 05, 2016 5:09 pm

Re: Issue in running Yambo

Post by lamia » Tue Dec 18, 2018 12:59 pm

Dear Daniele,

Thank you for your help. I have tried to do what you advise me to do and it works. But in other cases, I have already done it without any problem. So, I don't know what is the problem?

Best,
Lamia
Taouil Lamia
University of Mohammed V
Faculty of science - Rabat
Morocco

lamia
Posts: 12
Joined: Mon Dec 05, 2016 5:09 pm

Re: Issue in running Yambo

Post by lamia » Sun May 05, 2019 3:59 am

Hello Developers,

I'm doing all the steps of calculations without any problem but in the last step to run the calculation using yambo command line I 'm getting this error:
<---> [01] CPU structure, Files & I/O Directories
<---> [02] CORE Variables Setup
<---> [02.01] Unit cells
<---> [02.02] Symmetries
<---> [02.03] RL shells
<---> [02.04] K-grid lattice
<---> [02.05] Energies [ev] & Occupations
<---> [03] Transferred momenta grid
<---> [04] Optics
<---> [LA] SERIAL linear algebra

[ERROR] STOP signal received while in :[04] Optics
[ERROR]Allocation of X_mat failed

I would appreciate if you could help me resolve this issue.

Thanks,
Taouil Lamia
University of Mohammed V
Faculty of science - Rabat
Morocco

Online
User avatar
Daniele Varsano
Posts: 2128
Joined: Tue Mar 17, 2009 2:23 pm
Contact:

Re: Issue in running Yambo

Post by Daniele Varsano » Sun May 05, 2019 9:46 am

Dear Taouil Lamia,
it could be you are running out of memory, anyway, it is hard to say with the few information you reported.
Please attach your input and report files and we will have a look.

Best,

Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/

Post Reply