About error in p2y

Come here to discuss issues with using the p2y converter from PWscf to Yambo, how to best run PWscf , link with the IOTK library, and so on.

Moderator: Conor Hogan

Forum rules
Before posting, make sure to first read carefully all the detailed steps and suggestions given in the main documentation:
http://www.yambo-code.org/doc/databases/index.php
Post Reply
Bo Peng
Posts: 3
Joined: Tue Feb 04, 2020 5:47 pm

About error in p2y

Post by Bo Peng » Wed Feb 05, 2020 1:55 pm

Dear Yambo team,

I received an error message when running p2y (attached below). I think that is related to the format of my pseudopotential (I tried both PBE and PBEsol fr-nc pp from Pseudo Dojo). Could you please help me with that? Thank you very much and I am looking forward to your reply!


Best regards,
Bo

error message:

<24s> == DB3 (PseudoPotential) ...########################################################################################################################
# WARNING: there are pending errors
# PENDING ERROR (ierr=1)
# ERROR IN: iotk_open_read (iotk_files.F:663)
# CVS Revision: 1.20
# unit
file=.//data-file.xml
binary=F
iostat=29
# PENDING ERROR (ierr=2)
# ERROR IN: iotk_scan_empty (iotk_scan.F:440)
# CVS Revision: 1.23
# Tag not found
namel=fft_grid
# PENDING ERROR (ierr=3)
# ERROR IN: iotk_scan_empty (iotk_scan.F:440)
# CVS Revision: 1.23
# Tag not found
namel=fft_smooth
# FROM IOTK LIBRARY, VERSION 1.2.0
# UNRECOVERABLE ERROR (ierr=4)
# ERROR IN: iotk_getline (iotk_scan.F:1010)
# CVS Revision: 1.23
#
iostat=-1
# ERROR IN: iotk_scan_tag (iotk_scan.F:745)
# CVS Revision: 1.23
# ERROR IN: iotk_scan (iotk_scan.F:934)
# CVS Revision: 1.23
# ERROR IN: iotk_scan_begin (iotk_scan.F:94)
# CVS Revision: 1.23
########################################################################################################################
Bo Peng
PhD student in Physics
Cavendish Laboratory, University of Cambridge, UK

andrea.ferretti
Posts: 123
Joined: Fri Jan 31, 2014 11:13 am

Re: About error in p2y

Post by andrea.ferretti » Wed Feb 05, 2020 2:10 pm

Dear Bo,

this error is typically related to a mistake in the parsing of the pseudopot file.
Which version of yambo are you using ? Recently we have fixed a similar problem with v4.5.
If you are using an older version, perhaps 4.5 already fixes the problem.

Otherwise, can you post the pseudopot you are using ? (ideally also a scf input file that generates the problematic dft data).

best
Andrea
Andrea Ferretti, PhD
CNR-NANO-S3 and MaX Centre
via Campi 213/A, 41125, Modena, Italy
Tel: +39 059 2055322; Skype: andrea_ferretti
URL: http://www.nano.cnr.it

Bo Peng
Posts: 3
Joined: Tue Feb 04, 2020 5:47 pm

Re: About error in p2y

Post by Bo Peng » Wed Feb 05, 2020 5:43 pm

Dear Andrea,

Thank you for your kind help! In fact I used Yambo 4.5. Please find my pseudopotential (and input) below. Thanks once again!


Cheers,
Bo
You do not have the required permissions to view the files attached to this post.
Bo Peng
PhD student in Physics
Cavendish Laboratory, University of Cambridge, UK

Bo Peng
Posts: 3
Joined: Tue Feb 04, 2020 5:47 pm

Re: About error in p2y

Post by Bo Peng » Fri Feb 07, 2020 12:52 pm

Dear Andrea,

I think in the input file the encut and k-sampling is very large. Please feel free to reduce them. Sorry I just realized that. Thank you very much!


Best regards,
Bo
Bo Peng
PhD student in Physics
Cavendish Laboratory, University of Cambridge, UK

andrea.ferretti
Posts: 123
Joined: Fri Jan 31, 2014 11:13 am

Re: About error in p2y

Post by andrea.ferretti » Fri Feb 07, 2020 4:08 pm

Thanks,
I was indeed able to reproduce the problem. Looking now into it.
Andrea
Andrea Ferretti, PhD
CNR-NANO-S3 and MaX Centre
via Campi 213/A, 41125, Modena, Italy
Tel: +39 059 2055322; Skype: andrea_ferretti
URL: http://www.nano.cnr.it

andrea.ferretti
Posts: 123
Joined: Fri Jan 31, 2014 11:13 am

Re: About error in p2y

Post by andrea.ferretti » Fri Feb 07, 2020 6:09 pm

Dear Bo,

while version 4.5.0 compiled from the release tarball shows the problem, a fresh clone of the yambo-gpl repository
(which should be pretty identical) doesn't.
Moreover, in both cases (including the one that fails), all files are properly written in the SAVE directory, and then yambo initializes the DBs correctly.

I think the reading error that gives the problem is probably related to the closing of some UPF files and seems to be harmless (still to be investigated since should clearly not appear).

Andrea
Andrea Ferretti, PhD
CNR-NANO-S3 and MaX Centre
via Campi 213/A, 41125, Modena, Italy
Tel: +39 059 2055322; Skype: andrea_ferretti
URL: http://www.nano.cnr.it

Post Reply