Page 1 of 1

Strange error importing wave-functions

PostPosted: Wed Oct 21, 2015 1:10 pm
by javad
Dear Yambo developers

I noticed that if I import a wave-function from QuantumEspresso with few k-points I get
sometime an error in netcdf.

If I compile yambo with boundary checks FCFLAGS="-O1 -fcheck=bounds" in gfortran,
I get this error message:

...............
<---> :: Max atoms/species : 1
<---> == DB1 (Gvecs and more) ...At line 734 of file netcdf_expanded.f90
Fortran runtime error: Index '4' of dimension 2 of array 'values' above upper bound of 3
.............

when I use more k-points in the nscf the error disappears

I used QuantumEspresso 5.0.3 and Yambo 4.0.1

I attach the inputs

regards
Javad

Re: Strange error importing wave-functions

PostPosted: Wed Oct 21, 2015 2:17 pm
by andrea.ferretti
Hi Javad,

thanks for posting. I am trying to reproduce your error. I'll let you know asap
Andrea

Re: Strange error importing wave-functions

PostPosted: Wed Oct 21, 2015 6:15 pm
by andrea.ferretti
hi Javad,

I was able to reproduce your problem both using gfortran and ifort. The bug showed to be an interesting one
since it seems to be related to a print (debug-like) command left inside the netcdf-4.1.3 fortran interfaces.
Such interfaces were also downloaded by yambo. The print instruction was the one responsible for the
appearance from time to time of 4 integers in the log files.

Now, I've fixed the netcdf tar ball. This is going to appear in the new release of the code (due soon).
In order to get it in your local version, you need to overwrite the file
yambo/lib/archive/package.list
with the one attached (which seems to solve the problem in my case).

thanks for reporting
Andrea