qe 6.2 and p2y not compatible?

Come here to discuss issues with using the p2y converter from PWscf to Yambo, how to best run PWscf , link with the IOTK library, and so on.

Moderator: Conor Hogan

Forum rules
Before posting, make sure to first read carefully all the detailed steps and suggestions given in the main documentation:
http://www.yambo-code.org/doc/databases/index.php

qe 6.2 and p2y not compatible?

Postby chwolf » Sun Jan 21, 2018 9:40 am

Dear all,

I recently started using qe 6.2 but I found that the yambo stable and devel shipped with it seems incompatible, more precisely the p2y interface has some troubles with the qe version resulting in a complaint that the data-file xml (in qe 6.2 data-file-schema.xml ?) cannot be found and the version is not listed:
Code: Select all
hBN_2D.save$ ~/Downloads/qe-6.2/yambo-devel/bin/p2y


 __   __  _______  __   __  _______  _______
|  | |  ||   _   ||  |_|  ||  _    ||       |
|  |_|  ||  |_|  ||       || |_|   ||   _   |
|       ||       ||       ||       ||  | |  |
|_     _||       ||       ||  _   | |  |_|  |
  |   |  |   _   || ||_|| || |_|   ||       |
  |___|  |__| |__||_|   |_||_______||_______|


 <---> DBs path set to .
 <---> Index file set to data-file.xml
 <---> Index file not found! Check p2y version...STOP 


renaming the xml file

Code: Select all
____    ____    ___      .___  ___.  .______     ______
\   \  /   /   /   \     |   \/   |  |   _  \   /  __  \
 \   \/   /   /  ^  \    |  \  /  |  |  |_)  | |  |  |  |
  \_    _/   /  /_\  \   |  |\/|  |  |   _  <  |  |  |  |
    |  |    /  _____  \  |  |  |  |  |  |_)  | |  `--"  |
    |__|   /__/     \__\ |__|  |__|  |______/   \______/



 <---> DBs path set to .
 <---> Index file set to data-file.xml
[ERROR]Error in Read pwscf version  variables pwscf_current_version not present ierr:  1


I wonder if this is the current state or if I did something wrong during compilation? ;(

Thanks in advance for your help!

Chris
Christoph Wolf

Postech university, South Korea
chwolf@postech.ac.kr
chwolf
 
Posts: 12
Joined: Mon Jul 11, 2016 2:11 pm
Location: South Korea

Re: qe 6.2 and p2y not compatible?

Postby Daniele Varsano » Fri Jan 26, 2018 7:25 am

Dear Chris,
most probably there is a problem with the configuration. Can you try with a yambo version downloaded from the Yambo repository?
You can follow the instructions reported here:
http://www.yambo-code.org/download/index.php

We will have a look at the problem you pointed out in the qe repository. Thanks for reporting.

Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 1948
Joined: Tue Mar 17, 2009 2:23 pm

Re: qe 6.2 and p2y not compatible?

Postby andrea.ferretti » Mon Jan 29, 2018 4:24 pm

Hi Chris,

Currently, QE-6.2 downloads yambo 4.1.3 as yambo-devel. Unless you compile QE with the flag -D__OLDXML, Yambo won't be compatible, as you observe.
Yambo v4.2 is instead compatible with QE >= 6.2, and should be used if you want to use the new xml schema fmt.

While the automatic download of QE is being fixed, in order to directly interface with QE >= 6.2 the easiest way is to download Y 4.2.1
(eg https://github.com/yambo-code/yambo/arc ... 2.1.tar.gz) and compile it using the configure flag

Code: Select all
--with-p2y-version=qexsd


take care
Andrea
Andrea Ferretti, PhD
CNR-NANO-S3 and MaX Centre
via Campi 213/A, 41125, Modena, Italy
Tel: +39 059 2055322; Skype: andrea_ferretti
URL: http://www.nano.cnr.it
andrea.ferretti
 
Posts: 94
Joined: Fri Jan 31, 2014 11:13 am

Re: qe 6.2 and p2y not compatible?

Postby andrea.ferretti » Mon Jan 29, 2018 11:00 pm

Dear Chris,

further to my previous email, we have upgraded the version of Yambo downloaded by QE (including qe-6.2) to yambo v4.2.1,
for both "yambo" and "yambo-devel" targets.
If you start the process of compiling yambo via QE, it should now work for qe-6.2 .
(do not forget to do a make distclean before recompiling yambo).
Both
Code: Select all
make yambo

and
Code: Select all
make yambo-devel

would do

cheers
Andrea
Andrea Ferretti, PhD
CNR-NANO-S3 and MaX Centre
via Campi 213/A, 41125, Modena, Italy
Tel: +39 059 2055322; Skype: andrea_ferretti
URL: http://www.nano.cnr.it
andrea.ferretti
 
Posts: 94
Joined: Fri Jan 31, 2014 11:13 am

Re: qe 6.2 and p2y not compatible?

Postby chwolf » Thu Feb 01, 2018 8:36 am

Thank you all!

Works great now! :)

Best,
Chris
Christoph Wolf

Postech university, South Korea
chwolf@postech.ac.kr
chwolf
 
Posts: 12
Joined: Mon Jul 11, 2016 2:11 pm
Location: South Korea


Return to PW

Who is online

Users browsing this forum: No registered users and 1 guest