Page 1 of 1

Bug report in p2y

PostPosted: Mon Jan 29, 2018 12:35 pm
by sponce
Hello,

This is simply a bug report. I'm using Yambo 4.2.0 and q-e-6.0.

It seems that p2y cannot cope with imposing the k-point grid in the nscf step:

..
nosym = .true.
..
K_POINTS crystal
64
0.00000000 0.00000000 0.00000000 1.562500e-02
0.00000000 0.00000000 0.25000000 1.562500e-02
0.00000000 0.00000000 0.50000000 1.562500e-02
0.00000000 0.00000000 0.75000000 1.562500e-02
0.00000000 0.25000000 0.00000000 1.562500e-02
0.00000000 0.25000000 0.25000000 1.562500e-02
0.00000000 0.25000000 0.50000000 1.562500e-02
0.00000000 0.25000000 0.75000000 1.562500e-02
0.00000000 0.50000000 0.00000000 1.562500e-02
0.00000000 0.50000000 0.25000000 1.562500e-02
0.00000000 0.50000000 0.50000000 1.562500e-02


Indeed, if you do that in QE, it will produce a "charge-density.dat" file that does NOT have G-VECTORS. Also the associated gvector.dat is not created. I believe this is intended in QE.

However in interfaces/p2y/qexml.F the code is looking for CALL iotk_scan_begin( iunit, "G-VECTORS", IERR=ierr ) and therefore crash.

It does work if you using
Code: Select all
K_POINTS {automatic}
 4 4 4 0 0 0

instead in the nscf step.

Best,
Samuel

Re: Bug report in p2y

PostPosted: Mon Jan 29, 2018 12:57 pm
by Daniele Varsano
Dear Samuel,
there should a way to fix this within QE.
the wf_collect flag set as .true. in the nscf input should fix the problem.
In case this does not work can you upload th scf/nscf/psp input files?

Best,

Daniele

Re: Bug report in p2y

PostPosted: Mon Jan 29, 2018 3:07 pm
by andrea.ferretti
also note that
Code: Select all
wf_collect=.true.

needs to be there in nscf runs anyway in order to run p2y

Andrea

Re: Bug report in p2y

PostPosted: Mon Jan 29, 2018 6:41 pm
by sponce
Dear Andrea and Daniele,

I do confirm that I did not include the wf_collect=.true. flag.
It does indeed work with the flag.

Thank you !
Best