Page 1 of 1

QE 6.8 and Yambo 5

Posted: Thu Sep 30, 2021 3:17 pm
by chwolf
Hi guys,

is the new QE not compatible with Yambo 5? The input variable wf_collect has now become obsolete but p2y complains:

Error in routine p2y_init (1):
QE format not recognised/compatible (was wf_collect set to true?)


My versions: Program PWSCF v.6.8 starts on 30Sep2021 at 22: 6:28
This is yambo - MPI+OpenMP+SLEPC+HDF5_MPI_IO - Ver. 5.0.4 Revision 19595 Hash 896bffc02

Any help is as always much appreciated!

Best,
Chris

Re: QE 6.8 and Yambo 5

Posted: Thu Sep 30, 2021 4:15 pm
by chwolf
Ok, after deleting my temp folder and running it again it seems to be working, so don't mind my first post!

Re: QE 6.8 and Yambo 5

Posted: Thu Sep 30, 2021 4:41 pm
by andrea.ferretti
Hi Chris,

good to hear everything is solved!.
Indeed, Yambo and QE-6.8 are compatible.

Andrea

Re: QE 6.8 and Yambo 5

Posted: Sat Oct 23, 2021 12:50 pm
by chwolf
Dear Andrea,

thank you for your reply - unfortunately there still seems to be *some* hiccup in my system. I realized that I loaded qe-6.6 in the previous test by accident (smart me...) The following input still does not work for QE 6.8 and Yambo 5.4 for me:

Code: Select all

&CONTROL
calculation = "nscf" 
prefix = "pentacene"
 pseudo_dir         ='./'
outdir = "./tmp"
wf_collect = .true
tprnfor = .true.
restart_mode = "from_scratch"
/ 
&SYSTEM
ibrav = 6
A=  16
C=  12.0
nat  = 12
ntyp = 2
occupations = "fixed"
degauss = 0.002
smearing = 'mv'
ecutwfc = 90
vdw_corr = 'grimme-d3'
force_symmorphic = .true.
nbnd = 300
/ 
&ELECTRONS
 diago_full_acc = .true.
 conv_thr=1e-9
 electron_maxstep = 350 
/ 
&IONS
/

ATOMIC_SPECIES
C     12.0107    C_ONCV_PBE_sr.upf
H      1.0000    H_ONCV_PBE_sr.upf

ATOMIC_POSITIONS (angstrom)
C             5.6497869241        7.3791586080        3.4999999441
C             6.8594496181        6.6807537968        3.4999999904
C             6.8594503120        5.2839657372        3.5000000345
C             5.6497871545        4.5855610498        3.5000001317
C             4.4401242021        5.2839650480        3.5000000227
C             4.4401238390        6.6807556092        3.5000000230
H             5.6497866820        8.4678693247        3.4999999458
H             7.8023015923        7.2251135932        3.4999999993
H             7.8023016184        4.7396060135        3.4999999744
H             5.6497863670        3.4968516041        3.5000000091
H             3.4972728904        4.7396067440        3.4999999446
H             3.4972728001        7.2251128715        3.4999999804

K_POINTS automatic
 1 1 1 0 0 0

Code: Select all

     Program PWSCF v.6.8 starts on 23Oct2021 at 20:19:49 

     This program is part of the open-source Quantum ESPRESSO suite
     for quantum simulation of materials; please cite
cd into the save folder

p2y -H

Code: Select all

 This is p2y 4.5.2 rev.171
 P(Wscf) 2 Y(ambo) interface 
p2y

Code: Select all

 <---> DBs path set to .
 <---> detected QE data format: qexsd
 <---> == PWscf v.6.x generated data (QEXSD fmt) ==
 <---> Header/K-points/Energies...
 %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
     Error in routine qexsd_read_symmetry (2):
     fmt problem
 %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

     stopping ...
Abort(2) on node 0 (rank 0 in comm 0): application called MPI_Abort(MPI_COMM_WORLD, 2) - process 0

again it works flawlessly with QE 6.6 using exactly the same input

I did a diff on the xml files because sometimes the format changes but in this case that does not seem to be the culprit here:

Code: Select all

diff 6.6.xml  6.8.xml 
2c2
< <qes:espresso xsi:schemaLocation="http://www.quantum-espresso.org/ns/qes/qes-1.0 http://www.quantum-espresso.org/ns/qes/qes_200420.xsd" Units="Hartree atomic units" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:qes="http://www.quantum-espresso.org/ns/qes/qes-1.0">
---
> <qes:espresso xsi:schemaLocation="http://www.quantum-espresso.org/ns/qes/qes-1.0 http://www.quantum-espresso.org/ns/qes/qes_210716.xsd" Units="Hartree atomic units" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:qes="http://www.quantum-espresso.org/ns/qes/qes-1.0">
5,7c5,7
<     <xml_format NAME="QEXSD" VERSION="20.04.20">QEXSD_20.04.20</xml_format>
<     <creator NAME="PWSCF" VERSION="6.6">XML file generated by PWSCF</creator>
<     <created DATE="23Oct2021" TIME="19:36: 4">This run was terminated on:  19:36: 4  23 Oct 2021</created>
---
>     <xml_format NAME="QEXSD" VERSION="21.07.16">QEXSD_21.07.16</xml_format>
>     <creator NAME="PWSCF" VERSION="6.8">XML file generated by PWSCF</creator>
>     <created DATE="23Oct2021" TIME="20:30:22">This run was terminated on:  20:30:22  23 Oct 2021</created>
349d348
<       <do_magnetization>false</do_magnetization>
354,356c353,355
<       <ehart>8.664925433211726e1</ehart>
<       <vtxc>-1.670402688508456e1</vtxc>
<       <etxc>-1.491612111482527e1</etxc>
---
>       <ehart>8.664925433211732e1</ehart>
>       <vtxc>-1.670402688508457e1</vtxc>
>       <etxc>-1.491612111482528e1</etxc>
368,370c367,369
<       <fermi_energy>-2.245159265172052e-1</fermi_energy>
<       <highestOccupiedLevel>-2.245159265172052e-1</highestOccupiedLevel>
<       <lowestUnoccupiedLevel>-3.674129894031269e-2</lowestUnoccupiedLevel>
---
>       <fermi_energy>-2.245159265172038e-1</fermi_energy>
>       <highestOccupiedLevel>-2.245159265172038e-1</highestOccupiedLevel>
>       <lowestUnoccupiedLevel>-3.674129894031253e-2</lowestUnoccupiedLevel>
Any idea what I should be looking for..?

Best,
Chris

Re: QE 6.8 and Yambo 5

Posted: Sat Oct 23, 2021 2:41 pm
by andrea.ferretti
Dear Chris,

I gave a try to your input files and I was not able to reproduce the problem.
I have run pw using gnu 7.3.1, and then used yambo 5.0.4 (both gnu and intel 19.1.0.66) and it works well...
I have run first a scf and then a nscf calculation. Attached the precise input files I've used.

Andrea

Re: QE 6.8 and Yambo 5

Posted: Sat Oct 23, 2021 2:42 pm
by chwolf
Sorry, I should not install yambo 4 in a folder called yambo 5 and vice versa, I have no idea how that happened but finally, the mystery is solved - I apologize for keeping you all updated on my stupid journey ;)

Somehow the version numbering 4.5.x and 5.0.4 really scrambled my brain....

Chris

Re: QE 6.8 and Yambo 5

Posted: Sat Oct 23, 2021 2:44 pm
by andrea.ferretti
ahahah...
let's put it in this way: we had the opportunity to run some extra checks and everything works fine :-)

Re: QE 6.8 and Yambo 5

Posted: Sat Oct 23, 2021 2:46 pm
by chwolf
andrea.ferretti wrote:
Sat Oct 23, 2021 2:44 pm
ahahah...
let's put it in this way: we had the opportunity to run some extra checks and everything works fine :-)
Sorry I sent you on this journey Andrea, I hope I can make it up to you at a Yambo school in the future, I promise I won't forget about it! :D