Abinit version suitable for Yambo 4

Forum for discussing issues arising with interfacing the Abinit code (KSS) file with Yambo.

Moderator: Conor Hogan

Abinit version suitable for Yambo 4

Postby shaldar » Thu May 19, 2016 3:39 pm

Dear All,

I have question regarding importing database from Abinit to Yambo.
I am trying to use the latest Abinit 7.10.5 with Yambo 4.0.2 r.96. I am using norm conserving HGH pseudo potential for the DFT calculation using abinit.
Using the above mentioned pseudo potential, the latest Abinit does not generate the KSS file. If any Yambo user using Abinit for their DFT calculation then can you please recommend which abinit version to use ?

Regards

Soumyajyoti
Soumyajyoti Haldar
PhD student
Div. of Materials Theory
Dept. of Physics & Astronomy
Uppsala University, Sweden
shaldar
 
Posts: 17
Joined: Mon Apr 13, 2015 1:33 pm

Re: Abinit version suitable for Yambo 4

Postby Daniele Varsano » Thu May 19, 2016 7:09 pm

Dear Soumyajyoti,
I do not think that the problem is related with the used pseudopotential.
Could you please post here your abinit input file? We will try to spot the problem.

Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 1996
Joined: Tue Mar 17, 2009 2:23 pm

Re: Abinit version suitable for Yambo 4

Postby shaldar » Fri May 20, 2016 11:00 am

Dear Daniele,

Here is the input file attached. I am using Abinit 7.10.5 version compiled with following options
Code: Select all
../configure --with-trio-flavor=netcdf+etsf_io --enable-mpi --with-dft-flavor=libxc MPI_RUNNER=mpirun CC=mpicc FC=mpif90 --prefix=/scratch/work/user/prace/pr1s0082/abinit_new --exec-prefix=/scratch/work/user/prace/pr1s0082/abinit_new --with-fft-flavor=fftw3 --with-fft-incs=-I/apps/all/imkl/11.3.1.150-iimpi-2016.01-GCC-4.9.3-2.25/mkl/include/fftw --with-fft-libs=-L/apps/all/imkl/11.3.1.150-iimpi-2016.01-GCC-4.9.3-2.25/mkl/lib/intel64 -lfftw3xf_intel --with-linalg-flavor=mkl --with-linalg-libs=-L/apps/all/imkl/11.3.1.150-iimpi-2016.01-GCC-4.9.3-2.25/mkl/lib/intel64 -lmkl_blas95_lp64 -lmkl_lapack95_lp64 -lmkl_intel_lp64 -lmkl_core -lmkl_sequential -lpthread -lm -ldl --enable-64bit-flags


There is a patch.Yambo file included in the 7.10.5 version, but that does not patch the source code. So that is why I was wondering which version of Abinit to use.

Thanks for your help.

Regards

Soumyajyoti
You do not have the required permissions to view the files attached to this post.
Soumyajyoti Haldar
PhD student
Div. of Materials Theory
Dept. of Physics & Astronomy
Uppsala University, Sweden
shaldar
 
Posts: 17
Joined: Mon Apr 13, 2015 1:33 pm

Re: Abinit version suitable for Yambo 4

Postby Daniele Varsano » Fri May 20, 2016 11:19 am

Dear Soumyajyoti,
the last release I was using is the 7.10.2

We will investigate anway the issue of the 7.10.5 and let you know.
Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 1996
Joined: Tue Mar 17, 2009 2:23 pm

Re: Abinit version suitable for Yambo 4

Postby senersen » Tue Aug 02, 2016 9:50 am

I am using yambo-4.0.2-rev.90 (newly installed). Also, i am using abinit-8.0.7 (newly installed).

Abinit creates the KSS file. However, when i use a2y i get the following error:

forrtl: severe (67): input statement requires too much data, unit 11, file /home/sener/test/abinit_test/yambo/output_DS2_KSS
Image PC Routine Line Source
a2y 0000000000566603 Unknown Unknown Unknown
a2y 000000000058F9C6 Unknown Unknown Unknown
a2y 000000000058D583 Unknown Unknown Unknown
a2y 000000000041CB81 Unknown Unknown Unknown
a2y 0000000000422DC5 Unknown Unknown Unknown
a2y 0000000000422391 Unknown Unknown Unknown
a2y 000000000040C57E Unknown Unknown Unknown
libc.so.6 000000357CE1ECDD Unknown Unknown Unknown
a2y 000000000040B7A9 Unknown Unknown Unknown

Can it be due to that these two versions are not compatible or do you think there is another reason behind it?

My script for using a2y is the following;

#!/bin/bash
#SBATCH --nodes=1
#SBATCH --time=48:00:00
#SBATCH --ntasks-per-node=8
#SBATCH --job-name=deneme-a
#SBATCH --output=out.gw.job
#SBATCH --error=err.gw.job
#SBATCH --partition=12_cores
#SBATCH --exclusive

#load the environment

#. /etc/profile
#. $HOME/.bashrc

module purge
module load intel/2016a
module load libxc
module load HDF5
module load netCDF
module load netCDF-Fortran
module load QuantumESPRESSO
module load FFTW
module load ETSF_IO

YAMBO=/home/robert/Programs/yambo_hcp/yambo-4.0.2-rev.90/bin/a2y

srun -n12 $YAMBO -N -F output_DS2_KSS
Nano-bio Spectroscopy Group European Theoretical Spectroscopy Facility (ETSF) Dpto. Física de Materiales, UPV/EHU
Centro Joxe Mari Korta Avda. de Tolosa, 72 2º piso 20018 Donostia - San Sebastián, Spain
Tel: +34-943018840 Fax: +34-943018390
senersen
 
Posts: 13
Joined: Mon Aug 01, 2016 2:12 pm
Location: Spain

Re: Abinit version suitable for Yambo 4

Postby Davide Sangalli » Fri Aug 05, 2016 12:09 am

Dear senersen,
with the version 8 of abinit the header of the KSS file was changed.
Thus a2y does not work anymore.
We will probably release a new interface compatible with abinit >= 8.0 in September.

Up to September you can use any abinit version prior to 8.0

Best,
D.
Davide Sangalli, PhD
CNR-ISM, Division of Ultrafast Processes in Materials (FLASHit) and MaX Centre
http://www.ism.cnr.it/en/davide-sangalli-cv/
http://www.max-centre.eu/
User avatar
Davide Sangalli
 
Posts: 315
Joined: Tue May 29, 2012 4:49 pm
Location: Via Salaria Km 29.3, CP 10, 00016, Monterotondo Stazione, Italy

Re: Abinit version suitable for Yambo 4

Postby senersen » Fri Aug 05, 2016 3:16 pm

Thank you very much.

Cheers

sener
Nano-bio Spectroscopy Group European Theoretical Spectroscopy Facility (ETSF) Dpto. Física de Materiales, UPV/EHU
Centro Joxe Mari Korta Avda. de Tolosa, 72 2º piso 20018 Donostia - San Sebastián, Spain
Tel: +34-943018840 Fax: +34-943018390
senersen
 
Posts: 13
Joined: Mon Aug 01, 2016 2:12 pm
Location: Spain

Re: Abinit version suitable for Yambo 4

Postby Davide Sangalli » Thu Aug 11, 2016 8:32 am

Dear senersen,
I did some test, with abinit 8.0 and above, a2y does not work anymore, but you can still use e2y.

This is the procedure:
1) compile abinit with etsf-io:
configure --with-trio-flavor="netcdf+etsf_io --prefix="$ABI_INSTALL_PATH" --exec-prefix="$ABI_INSTALL_PATH"
make abinit
make install

2) run abinit with the input variable
iomode 3

3) Compile yambo linking the etsf-io library of abinit
configure --with-etsf-io-path="$ABI_INSTALL_PATH/fallbacks/exports/"

4) run the e2y (etsf2yambo) converter
e2y -F $JOB_o_DS2_KSS.nc

D.
Davide Sangalli, PhD
CNR-ISM, Division of Ultrafast Processes in Materials (FLASHit) and MaX Centre
http://www.ism.cnr.it/en/davide-sangalli-cv/
http://www.max-centre.eu/
User avatar
Davide Sangalli
 
Posts: 315
Joined: Tue May 29, 2012 4:49 pm
Location: Via Salaria Km 29.3, CP 10, 00016, Monterotondo Stazione, Italy

Re: Abinit version suitable for Yambo 4

Postby Flex » Wed Mar 01, 2017 4:35 pm

Hello,

Has there been some progress on this matter ? I use the latest version of Abinit (8.2) and Yambo 4.1.2 and I was wondering if the incompatibility for a2y had been fixed.

Thanks in advance,

Thierry
Thierry Clette
Student at Université Libre de Bruxelles, Belgium
Flex
 
Posts: 37
Joined: Fri Mar 25, 2016 4:21 pm

Re: Abinit version suitable for Yambo 4

Postby Davide Sangalli » Thu Mar 02, 2017 6:17 pm

Unfortunately not yet.
We worked on the abinit interface, but the only way to fix the a2y interfaces was to add many of the abinit source files in the yambo source.
We decided not to adopt such solution for many reasons.
Also because such solution is still based on the KSS file which is not developed any more by the abinit team
(although they just did some changes which broke the a2y interface)

Thus for the moment we do not have a solution.
I also understood that the ETSF-IO is going to be dropped by abint (another point we need to work on).

On our side we confirm the availability to restore the interface also with more recent version of abinit.
Indeed we tried to get in touch with the abinit team to find an appropriate solution, based on the direct conversion of the wave-functions files.
But there are more issues here (i.e. a way to import the kb form factors)
In any case we need some support/collaboration from the abinit team and we hope to receive it in the near future.

Best,
D.
Davide Sangalli, PhD
CNR-ISM, Division of Ultrafast Processes in Materials (FLASHit) and MaX Centre
http://www.ism.cnr.it/en/davide-sangalli-cv/
http://www.max-centre.eu/
User avatar
Davide Sangalli
 
Posts: 315
Joined: Tue May 29, 2012 4:49 pm
Location: Via Salaria Km 29.3, CP 10, 00016, Monterotondo Stazione, Italy

Next

Return to Abinit

Who is online

Users browsing this forum: No registered users and 1 guest