Page 2 of 2

Re: Abinit version suitable for Yambo 4

PostPosted: Sat Mar 04, 2017 12:27 pm
by Flex
Thanks for the detailed answer.

I will be using abinit 8.0.8 with etsf-io libraries and use e2y, that should be alright for the time being.

Re: Abinit version suitable for Yambo 4

PostPosted: Tue Apr 09, 2019 11:35 am
by Alesster
Hello,

Now it is already 2019 and I am interested in the same question:
Flex wrote:Has there been some progress on this matter ? I use the latest version of Abinit (8.2) and Yambo 4.1.2 and I was wondering if the incompatibility for a2y had been fixed.

Is this problem now fixed?

I tried to use Abinit v.8.6.3 and Yambo v.4.2.4

I could run the command
a2y -F KSS-file
and generate yambo.in with
yambo -i -V all

But then when I am running yambo it gives me error:
[02.01] Unit cells
==================

Unit cell is Unknown
==================

For the generation of KSS-file with abinit I use attached file.

Is it problem of version compatibility, abinit input or something else?

Thank you,
Sasha.

Re: Abinit version suitable for Yambo 4

PostPosted: Tue Apr 09, 2019 5:32 pm
by Davide Sangalli
Dear Aleksandr,
the new interface between abinit and yambo (based on the WFK files) has been coded and imported in the main branch of the development version.

This means that it is not yet available as a GPL release unfortunately, but it will be part of the next yambo release.
Likely in few months. For sure before the end of 2019, since a release is scheduled for November 2019 (MaX project).

Best,
D.

Re: Abinit version suitable for Yambo 4

PostPosted: Wed Apr 10, 2019 9:56 am
by Alesster
Davide Sangalli wrote:Dear Aleksandr,
the new interface between abinit and yambo (based on the WFK files) has been coded and imported in the main branch of the development version.

This means that it is not yet available as a GPL release unfortunately, but it will be part of the next yambo release.
Likely in few months. For sure before the end of 2019, since a release is scheduled for November 2019 (MaX project).

Best,
D.

Dear Davide,
Thank you for the fast reply.
So, it means if I use the official version of Abinit I need to use e2y. Isn't it?

It would be good if in the official Yambo web-page there is detail information about compatibility between different versions of Yambo and Abinit/QE. For the moment it is not clear what is compatible and what is not.

Thank you.
Sasha.