Pproblem in Lumen tutorial. Metallic system.

Anything regarding the post-processing utility (e.g. excitonic wavefunction analysis) is dealt with in this forum.

Moderators: Davide Sangalli, andrea marini, Daniele Varsano

Post Reply
Maksim
Posts: 2
Joined: Wed Nov 13, 2019 6:34 am

Pproblem in Lumen tutorial. Metallic system.

Post by Maksim » Wed Nov 13, 2019 10:04 am

Dear Yambo and Lumen users,
Performing the "SHG in AlAs" tutorial on Lumen web-site http://www.attaccalite.com/lumen/shg_in_AlAs.html, I faced the following problem. In r_setup output I have "[WARNING]Metallic system", which makes impossible later nonlinear calculation. However, AlAs has band gap.
I used hbn_out_DS2_KSS file from ABINIT caclulation.
Also the r_setup file says that there are 36 electrons while, according to pseudopotentials, there are only 8 electrons.
I strictly followed the tutorial steps and used tutorial's inputs for Lumen and Abinit.
What could be the problem?
Any suggestions would be highly appreciable! Thank You!

User avatar
claudio
Posts: 228
Joined: Tue Mar 31, 2009 11:33 pm
Contact:

Re: Pproblem in Lumen tutorial. Metallic system.

Post by claudio » Thu Nov 14, 2019 10:32 am

Dear Maksim

the hbn_out_DS2_KSS file is for the tutorial on hexagonal boron nitride (hBN) http://www.attaccalite.com/lumen/linear_response.html

for the AlAs you have to use Abinit input files and generate the KSS file: http://www.attaccalite.com/lumen/tutori ... abinit.tgz

let me know if you have problem to generate it

best
Claudio
Claudio Attaccalite
[CNRS/ Aix-Marseille Université/ CINaM laborarory / TSN department
Campus de Luminy – Case 913
13288 MARSEILLE Cedex 09
web site: http://www.attaccalite.com
Freely download scientific books from: http://www.freescience.info

Maksim
Posts: 2
Joined: Wed Nov 13, 2019 6:34 am

Re: Pproblem in Lumen tutorial. Metallic system.

Post by Maksim » Sat Nov 23, 2019 5:44 am

Dear Claudio ,

Sorry, it was a misprint. Actually, I used proper AsAl input. So, the problem is still present.

User avatar
claudio
Posts: 228
Joined: Tue Mar 31, 2009 11:33 pm
Contact:

Re: Pproblem in Lumen tutorial. Metallic system.

Post by claudio » Mon Nov 25, 2019 11:56 am

Dear Maksim

I repeated the calculation of AlAs with Yambo 4.4.0 and everything was fine.

https://github.com/yambo-code/yambo/wik ... -format%29

I used QuantumEpresso instead of Abinit, because I do not use the last one since long time.
I updated the Tutorial webpage, now you can find also the QE input files.

http://www.attaccalite.com/lumen/shg_in_AlAs.html

let me know if it works

Best
Claudio
Claudio Attaccalite
[CNRS/ Aix-Marseille Université/ CINaM laborarory / TSN department
Campus de Luminy – Case 913
13288 MARSEILLE Cedex 09
web site: http://www.attaccalite.com
Freely download scientific books from: http://www.freescience.info

User avatar
Davide Sangalli
Posts: 320
Joined: Tue May 29, 2012 4:49 pm
Location: Via Salaria Km 29.3, CP 10, 00016, Monterotondo Stazione, Italy
Contact:

Re: Pproblem in Lumen tutorial. Metallic system.

Post by Davide Sangalli » Thu Dec 05, 2019 11:25 am

Dear Maksim,
can you attach the input files you used for abinit, report the abinit version and finally attach the yambo report file.

Thanks,
D.
Davide Sangalli, PhD
CNR-ISM, Division of Ultrafast Processes in Materials (FLASHit) and MaX Centre
http://www.ism.cnr.it/en/davide-sangalli-cv/
http://www.max-centre.eu/

Post Reply