Errors for the band interpolation

Anything regarding the post-processing utility (e.g. excitonic wavefunction analysis) is dealt with in this forum.

Moderators: Davide Sangalli, Daniele Varsano, andrea marini

Errors for the band interpolation

Postby Tianshu » Mon Apr 22, 2019 3:43 am

Dear developers,

I want to plot the band structures with ypp, but there are some errors. When I finished my GW calculation, I used "ypp -s b ypp.in" and changed the relates parameters as following,
Code: Select all
#                                                           
#                                                           
# Y88b    /   e           e    e      888~~\    ,88~-_     
#  Y88b  /   d8b         d8b  d8b     888   |  d888   \     
#   Y88b/   /Y88b       d888bdY88b    888 _/  88888    |   
#    Y8Y   /  Y88b     / Y88Y Y888b   888  \  88888    |   
#     Y   /____Y88b   /   YY   Y888b  888   |  Y888   /     
#    /   /      Y88b /          Y888b 888__/    `88_-~     
#                                                           
#                                                           
#             GPL Version 4.1.3 Revision 76                 
#                      Serial Build                         
#               http://www.yambo-code.org                   
#
electrons                    # [R] Electrons (and holes)
bnds                         # [R] Bands
cooIn= "rlu"                 # Points coordinates (in) cc/rlu/iku/alat
BANDS_steps= 100             # Number of divisions
% INTERPGrid
-1 |-1 |-1 |                             # Interpolation BZ Grid
%
ShellFac= 20.00000           # The bigger it is a higher number of shells is used
shell is used
GfnQPdb= "E < gw/ndb.QP"     # [EXTQP G] Database
GfnQP_N = 1
%QPkrange                    #  generalized Kpoint/Band indices
 1 | 75|  14| 24|
%
%BKpts                       # K points of the bands circuit
0.00000 |0.00000 |0.00000 |
0.00000 |0.50000 |0.00000 |
-.33330 |0.66667 |0.00000 |
0.00000 |0.00000 |0.00000 |
%

However, the report files have some errors like,
Code: Select all
 __    __ ______           ____     _____
/\ \  /\ \\  _  \  /"\_/`\/\  _`\ /\  __`\
\ `\`\\/"/ \ \L\ \/\      \ \ \L\ \ \ \/\ \
 `\ `\ /" \ \  __ \ \ \__\ \ \  _ <" \ \ \ \
   `\ \ \  \ \ \/\ \ \ \_/\ \ \ \L\ \ \ \_\ \
     \ \_\  \ \_\ \_\ \_\\ \_\ \____/\ \_____\
      \/_/   \/_/\/_/\/_/ \/_/\/___/  \/_____/


 <---> [01] CPU structure, Files & I/O Directories
 <---> [02] Y(ambo) P(ost)/(re) P(rocessor)
 <---> [03] Core DB
 <---> :: Electrons             : 18.00000
 <---> :: Temperature       [ev]: 0.000000
 <---> :: Lattice factors [a.u.]:  5.97756   5.17672  38.66202
 <---> :: K points              :  75
 <---> :: Bands                 :  60
 <---> :: Symmetries            : 12
 <---> :: RL vectors            : 225887
 <---> [04] K-point grid
 <---> :: Q-points   (IBZ):  75
 <---> :: X K-points (IBZ):  75
 <---> [05] CORE Variables Setup
 <---> [05.01] Unit cells
 <---> [05.02] Symmetries
 <---> [05.03] RL shells
 <---> [05.04] K-grid lattice
 <---> [05.05] Energies [ev] & Occupations
 <---> [06] Interpolation tool
 <---> [06.01] Loading special Points for the HCP lattice
 <---> [06.02] External/Internal QP corrections
 <---> [WARNING]Wrong serial number for ./gw/ndb.QP
 <---> E<gw/ndb.QP[ E-E PPA: 27.21138 XG: 231 Xb:   1   50 Scb:   1   50]
 <---> [QP_ctl (Nearest K-pt)] Kpts covered exactly  [o/o]: 100.0000
 <---> [06.03] Interpolation@work: Circuit

[ERROR] STOP signal received while in :[06.03] Interpolation@work: Circuit
[ERROR] YPP cannot interpolate more than 20 bands. Reduce bands range


So my band number setting is not out of range, but the code prompts an error.
I find another post which has similar problem, http://www.yambo-code.org/forum/viewtopic.php?f=9&t=1281. But the proposed solution doesn't seem to work for me.
I also upload an attachment including gw files and ypp input. Thank you for your help and suggestions.

Best regards,
Tianshu
College of Materials Science and Engineering,
Jilin University, China
Institute http://dmse.jlu.edu.cn/?mod=info&act=view&id=502
Tianshu
 
Posts: 27
Joined: Wed Sep 20, 2017 8:36 am

Re: Errors for the band interpolation

Postby Daniele Varsano » Mon Apr 22, 2019 8:43 pm

Dear Tianshu,
it seems that the attached file are missing, or at least I can't see them.
From the ypp.in you posted it seems you are using a 4.1 version of Yambo, this is quite old and not maintained anymore.
Can you try to repeat your calculations using a more recent version? In the case, you are already using a recent version of yambo and just an old input,
I suggest you generate the input by scratch as the problem seems related that some variable is not read correctly.
Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/
User avatar
Daniele Varsano
 
Posts: 2027
Joined: Tue Mar 17, 2009 2:23 pm

Re: Errors for the band interpolation

Postby Tianshu » Wed Apr 24, 2019 7:48 am

Dear Daniele,

According your suggestion, I found I used yambo-4.3.2 to run a old ypp input, which was produced by yambo-4.1. So I reproduced a new ypp input and it can run well. Thank you!

Best regards,
Tianshu Li
College of Materials Science and Engineering,
Jilin University, China
Institute http://dmse.jlu.edu.cn/?mod=info&act=view&id=502
Tianshu
 
Posts: 27
Joined: Wed Sep 20, 2017 8:36 am


Return to Post Processing (ypp)

Who is online

Users browsing this forum: No registered users and 1 guest

cron