Segmentation fault p2y - qe 5.2.0, yambo 4.0.1

Come here to discuss issues with using the p2y converter from PWscf to Yambo, how to best run PWscf , link with the IOTK library, and so on.

Moderator: Conor Hogan

Forum rules
Before posting, make sure to first read carefully all the detailed steps and suggestions given in the main documentation:
http://www.yambo-code.org/doc/databases/index.php

Segmentation fault p2y - qe 5.2.0, yambo 4.0.1

Postby Michael.Friedrich » Tue Aug 25, 2015 2:07 pm

Hello,

by importing the databases from quantum espresso 5.2.0 (also tested 5.1.1 and 5.0.3) to yambo 4.0.1 I get the following error.

<---> DBs path set to .
<---> Index file set to data-file.xml
<---> Header/K-points/Energies... done
<---> Cell data... done
<---> Atomic data... done
<---> Symmetries...[SI no]...[I yes]...[-I no]...[TR yes][dhcp-n3physik-93:86516] *** Process received signal ***
[dhcp-n3physik-93:86516] Signal: Segmentation fault: 11 (11)
[dhcp-n3physik-93:86516] Signal code: (0)
[dhcp-n3physik-93:86516] Failing at address: 0x0
[dhcp-n3physik-93:86516] *** End of error message ***
Segmentation fault: 11


The same holds for qe 5.0.3 and yambo 3.4.1 installed on our cluster, though with a different error message
<---> P(W) 2 Y(ambo) Ver. 5.0
<---> DBs path set to .
<---> Index file set to data-file.xml
<---> Header/K-points/Energies...done
<---> Cell data...done
<---> Atomic data...done
<---> Symmetries...[SI no]...[I yes]...[-I no]...[TR yes][fe1:mpi_rank_0][error_sighandler] Caught error: Segmentation fault (signal 11)
Segmentation fault (core dumped)


Are the ONCV pseudopotentials which I (try to) use for my calculations a problem? I attached my calculation (input files, psps, data-file.xml).

Here's also my configuration file.
./configure \
PFC="/Users/michaelf/Tools/openmpi-1.8.8/intallation/bin/mpif90" \
MPICC="/Users/michaelf/Tools/openmpi-1.8.8/intallation/bin/mpicc" \
\
CC=/sw/lib/gcc4.9/bin/gcc-fsf-4.9 \
CPP="/sw/lib/gcc4.9/bin/cpp-fsf-4.9 -E -ansi" \
FC="/sw/lib/gcc4.9/bin/gfortran-fsf-4.9" \
F77=/sw/lib/gcc4.9/bin/gfortran-fsf-4.9 \
FCCPP=/sw/lib/gcc4.9/bin/cpp-fsf-4.9 FCFLAGS=-m64 CFLAGS=-m64 \
\
--enable-msgs-comps \
--enable-dp \
--enable-open-mp \
--with-mpi-libs="-L/Users/michaelf/Tools/openmpi-1.8.8/intallation/lib" \
\
--with-fft-libs="-L/sw/lib/ -lfftw3 -lfftw3f" --with-fft-includedir="-I/sw/include/ autoreconf -vif" \
\
--enable-iotk --with-iotk-path="/Users/michaelf/tools/espresso-5.2.0/iotk/" \
--with-p2y-version="5.0" \
\
--enable-netcdf-hdf5 \
--enable-netcdf-LFS \
--with-netcdf-path=/usr/local/ \
--with-hdf5-libdir=/usr/local/ \


Thank you for your help
Michael Friedrich
You do not have the required permissions to view the files attached to this post.
Michael Friedrich, Universität Paderborn, Germany
Michael.Friedrich
 
Posts: 15
Joined: Tue Aug 11, 2015 11:51 am

Re: Segmentation fault p2y - qe 5.2.0, yambo 4.0.1

Postby myrta gruning » Tue Aug 25, 2015 2:23 pm

dear Michael

I do not think it is related to the PP since it went through the atomic data part.
It may be related with the XC which is the next thing after symmetries. I remember the problem with the 3.4.1 though I thought that was fixed.
I will look at that. Thank you for signalling the seg fault.

Best,
m
Dr Myrta Grüning
Atomistic Simulation Centre
Queen's University Belfast - Northern Ireland

http://www.researcherid.com/rid/B-1515-2009
User avatar
myrta gruning
 
Posts: 303
Joined: Tue Mar 17, 2009 11:38 am

Re: Segmentation fault p2y - qe 5.2.0, yambo 4.0.1

Postby andrea.ferretti » Tue Aug 25, 2015 2:44 pm

Dear Michael,

I think Myrta is right, I had a similar problem and it was caused by the following lines of data-file.xml

Code: Select all
  <EXCHANGE_CORRELATION>
    <DFT type="character" size="1" len="20">
PZ
    </DFT>
  </EXCHANGE_CORRELATION>


Basically, PZ is used as a kind of jargon within QE, but it is not recognised by Yambo/libxc.
You can fix the problem by changing PZ to LDA or

Code: Select all
    <DFT type="character" size="1" len="20">
 SLA  PZ   NOGX NOGC
    </DFT>


Since PZ is allowed by QE, this has to be fixed within Yambo in one of the next releases.
Thanks for reporting

Andrea

BTW: note that the string bearing the XC name (PZ, LDA, or "SLA PZ NOGX NOGC") should be 20 digits long, as stated by the len attribute.
attention must be paid when replacing values
Last edited by andrea.ferretti on Tue Aug 25, 2015 3:25 pm, edited 1 time in total.
Andrea Ferretti, PhD
CNR-NANO-S3 and MaX Centre
via Campi 213/A, 41125, Modena, Italy
Tel: +39 059 2055322; Skype: andrea_ferretti
URL: http://www.nano.cnr.it
andrea.ferretti
 
Posts: 96
Joined: Fri Jan 31, 2014 11:13 am

Re: Segmentation fault p2y - qe 5.2.0, yambo 4.0.1

Postby Michael.Friedrich » Tue Aug 25, 2015 3:22 pm

Thank you very much for your very fast reply!
For the installation on the cluster the problem is solved with the suggested change in the xml file.
The problem for the local installation on my mac remains.
I copied the qe output LN.save to the cluster, imported the database with p2y and copied everything back to my mac and yambo works fine (so I can live with that ;) ).
I just wanted to let you know that If I use p2y on my mac I still obtain the segmentation fault posted above...

Best regards
Michael
Michael Friedrich, Universität Paderborn, Germany
Michael.Friedrich
 
Posts: 15
Joined: Tue Aug 11, 2015 11:51 am


Return to PW

Who is online

Users browsing this forum: No registered users and 1 guest

cron